使用TLS/SSH FIPS严格策略时、无法发送ASUP
适用场景
- StorageGRID 11.9
- AutoSupport
问题描述
- 将 StorageGRID 升级到 11.9.0.1 后,使用 TLS/SSH 安全 FIPS 严格策略时,每周 AutoSupport 和用户触发 AutoSupport 会失败。
- 在
/var/local/log/nms.log
Feb 13 16:52:04 Admin Node MI: |2025-02-13T16:52:04.674| ERROR [pool-2-thread-1] AsupUserAgentData.java:264: UserAgentFileItem general error
Feb 13 16:52:04 Admin Node java.io.IOException: Failed to load client keystore: /usr/local/mi/conf/nmskeystore.pkcs12
Feb 13 16:52:04 Admin Node MI: |2025-02-13T16:52:04.674| ERROR [pool-2-thread-1] AsupUserAgentData.java:243: Error while generating the ASUP xml data.
Feb 13 16:52:04 Admin Node MI: |2025-02-13T16:52:04.675| ERROR [pool-2-thread-1] UserAgentFileItem.java:170: Exception while creating useragents ASUP file
Feb 13 16:52:04 Admin Node MI: |2025-02-13T16:52:04.675| ERROR [pool-2-thread-1] ProductionDataFactory.java:260: Exception in creating zip file for http(s) autosupport message
Feb 13 16:52:04 Admin Node MI: |2025-02-13T16:52:04.675| ERROR [pool-2-thread-1] ProductionDataFactory.java:260: Exception in creating zip file for http(s) autosupport message