无法启动 StorageGRID 节点,因为块设备不存在
适用场景
- NetApp StorageGRID 11.3+
- StorageGRID 节点部署在 Linux 主机上的 Docker 容器中
问题描述
- StorageGRID 节点在 Linux 主机异常重新启动后不会自动启动。
- 节点容器报告"未运行"、由于出现错误、无法启动。
- 无法手动启动StorageGRID 节点、因为块设备不存在。
输出示例:
# storagegrid node start
ERROR: /etc/storagegrid/nodes/<node name>.conf contains errors; cannot start <node name>
Run 'storagegrid node validate <node name>' and correct any errors, then try again.
# storagegrid node validate <node name>
Confirming existence of node <node name>... PASSED
Checking configuration file /etc/storagegrid/nodes/<node name>.conf for node <node name>...
ERROR: <node name>: BLOCK_DEVICE_VAR_LOCAL = /dev/mapper/<node name>
<node name>: /dev/mapper/<node name> does not exist