跳转到主内容

升级管理节点后、StorageGRID nginx/gw服务无法启动

Views:
3
Visibility:
Internal
Votes:
0
Category:
storagegrid<a>2009年118615</a>
Specialty:
sgrid
Last Updated:

适用场景

StorageGRID 11.5、11.6.

问题描述

  • 在升级过程中、找不到SSL证书文件
  • servermanager.log 报告以下内容:
[2022-03-25T12:57:37.224] WARNING -- Configuration validation failed.
nginx: [warn] load balancing method redefined in /etc/nginx-gw/mgmt-api.conf:21
nginx: [warn] load balancing method redefined in /etc/nginx-gw/mgmt-api.conf:34
nginx: [emerg] BIO_new_file("/etc/nginx-gw/ssl.crt/server.crt") failed (SSL: error:02001002:system library:fopen:No such file or directory:fopen('/etc/nginx-gw/ssl.crt/server.crt','r') error:2006D080:BIO routines:BIO_new_file:no such file)
nginx: configuration file /etc/nginx-gw/nginx-gw.conf test failed

Sign in to view the entire content of this KB article.

New to NetApp?

Learn more about our award-winning Support

This is an internal KB article and its content should not be copy/pasted and shared with people outside of NetApp. Always seek Duty Manager authentication of caller for password reset requests. If you need further assistance post a question in Knowledge Xchange