跳转到主内容

StorageGRID 12.0.x 升级无法在主管理节点之外继续

Views:
29
Visibility:
Public
Votes:
0
Category:
storagegrid
Specialty:
esg
Last Updated:

适用于

  • NetApp StorageGRID

问题

  • 主管理节点成功升级后,StorageGRID 升级到 12.0.x 版本失败。
  • 在网格管理器中,underMaintenance > 软件更新 > StorageGRID 更新,升级报告以下错误。

Failed to start the upgrade service on one or more nodes. Details: An unknown GDU server error occurred. For more information, see gdu-server.log.

  • 在警报页面上观察到多个与 FIPS 启用相关的警报。
  • 此外,位于主管理节点 (/var/local/log) 上的 gdu-server.log 文件报告以下错误消息。

ERROR -- gdu-server: /usr/lib/ruby/3.1.0/tempfile.rb:358:in `create'
ERROR -- gdu-server: /usr/local/lib/site_ruby/bycast/tasks/gdu-server/ssh-add.rb:47:in `add!'
ERROR -- gdu-server: Task failed: "Upgrade Service Start"
ERROR -- gdu-server: #<RuntimeError: Failed to run ssh-add on node ash1psgan01>
ERROR -- gdu-server: /usr/local/lib/site_ruby/bycast/tasks/gdu-server/ssh-add.rb:104:in `rescue in call'
ERROR -- gdu-server: /usr/local/lib/site_ruby/bycast/tasks/gdu-server/ssh-add.rb:89:in `call'
ERROR -- gdu-server: /usr/local/lib/site_ruby/gdu/server.rb:320:in `maybe_run_ssh_add'
ERROR -- gdu-server: /usr/local/lib/site_ruby/gdu/server.rb:114:in `handle_request'
ERROR -- gdu-server: /usr/local/lib/site_ruby/gdu/server.rb:84:in `serve'
ERROR -- gdu-server: /usr/local/lib/site_ruby/gdu/server.rb:60:in `block (2 levels) in start'  

  • 尝试下载支持包或恢复包时,失败并显示以下错误:

An unknown GDU server error occurred. For more information, see gdu-server.log.

  • 使用 ssh-add 将 SSH 私钥重新添加到 SSH 身份验证代理失败,并显示以下错误:

# ssh-add
Enter passphrase for /root/.ssh/id_rsa:
Bad passphrase, try again for /root/.ssh/id_rsa:

Sign in to view the entire content of this KB article.

New to NetApp?

Learn more about our award-winning Support

NetApp provides no representations or warranties regarding the accuracy or reliability or serviceability of any information or recommendations provided in this publication or with respect to any results that may be obtained by the use of the information or observance of any recommendations provided herein. The information in this document is distributed AS IS and the use of this information or the implementation of any recommendations or techniques herein is a customer's responsibility and depends on the customer's ability to evaluate and integrate them into the customer's operational environment. This document and the information contained herein may be used solely in connection with the NetApp products discussed in this document.