之后, OnCommand Insight 数据仓库 "Informix" 服务无法启动 Windows 重新启动
状态信息
适用于
- OnCommand Insight 数据仓库 7.3.3 ( OCI DWH )
- Microsoft Windows Server
问题
- 重新启动后, "Informix IDS – ol_ceroscm" 服务无法启动。
- 如果手动启动服务、则会失败
The service did not start due to a logon failure.
原因
Informix 用户帐户密码已过期或已更改。
解决方案
- 如果密码已过期且不进行其他更改,则更新用户的密码策略足以解决此问题。
- 打开 DWH 服务器上的本地用户和组(
lusrmgr.msc
) - 在 用户下,检查 Informix 用户的属性
- 取消选中 用户下次登录时必须更改密码
- 选中 密码永不过期 ,然后单击确定进行保存
- 在 服务中,启动 Informix 和 Cognos 服务。为了方便起见,此处列出了所有四项服务:
- Apacheds-Cognos
- INFORMIX IDS 消息服务
- INFORMIX IDS-OL_CognSCM
- IBM Cognos
- 如果 "Informix" 密码已因策略而更改或必须更改,则必须在 IBM Cognos Configuration 中更新此密码,并在此服务中更新此密码。
- 打开 DWH 服务器上的本地用户和组(
lusrmgr.msc
) - 右键单击 Informix 用户,然后单击设置密码以设置密码
- 在 服务中,打开 "Informix IDS - ol_cinoscm" 服务的属性
- 选择登录选项卡,然后执行以下步骤之一:
- 更改登录以使用 本地系统帐户
- 更新 Informix 帐户的密码
- 启动 Informix IDS - ol_ceroscm 服务
- 以管理员身份启动 IBM Cognos 配置
- 导航至 Data Access -> Content Manager -> Content Store
- 编辑 用户 ID 和密码 字段并输入新密码
- 右键单击内容存储并选择测试 - 数据库连接测试应成功
- 右键单击“ Local Configuration ”(本地配置)并选择“ Start ”(开始)