ONTAP 集群中的 nblade.execsOverLimit 错误,由 Kubernetes 集群访问
适用于
- Kubernetes 集群
- NetApp Astra Trident
- NFSv3/v4
- Ontap 9.8+
问题
- PersistentVolumeClaims (PVC) 由 Trident 预配,间歇性地无法挂载到某些 OpenShift 节点或 Pod 上。
- 受影响的 Pod 长时间保持
ContainerCreating状态。 - 尝试从这些节点挂载 NFS 卷会导致
mount.nfs进程被阻塞数分钟。 - Pod 状态:
q-courier-deployment-xxxxxxx-xaaaaa 0/1 ContainerCreating 0 61m abcs - 内核日志 (dmesg):
[6xxxx0.3xxxx1] INFO: task mount.nfs:3xxxx1 blocked for more than 983 seconds. - ONTAP EMS:
Mon Jan 01 00:00:00 +0100 [node: kernel: nblade.execsOverLimit:error]: The number of in-flight requests from client with source IP XX.YY.ZZ.XX to destination LIF ZZ.YY.XX.YY (Vserver X) is greater than the maximum number of in-flight requests allowed (128). The client might see degraded performance due to request throttling