跳转到主内容

NetApp_Insight_2020.png 

从 7.2.x/7.3.x/9.4.x 到 9.5 版本的 Unified Manager 升级步骤

Views:
4
Visibility:
Public
Votes:
0
Category:
oncommand-unified-manager
Specialty:
om
Last Updated:

适用于

  • OnCommand Unified Manager 7.2.x
  • OnCommand Unified Manager 7.3.x
  • OnCommand Unified Manager 9.4.x
  • OnCommand Unified Manager 9.5

解答

简介

由于性能数据表的不同, Unified Manager 数据库备份大小可能会增加。因此、使用 Unified Manager 实例管理更大占用空间的客户在从 7.3.x/7.3.x 至 9.4( 或 ) 版本 7.3.x->9.5 升级实例时可能会遇到问题。

本文旨在帮助客户了解有关如何计划从 7.2.x/7.3.x/9.4 版升级到 9.5 版的统一管理器升级的通用指南。这篇文章还有助于以更明确的格式规划 Unified Manager 数据库备份、从而帮助客户在长期内更快地恢复数据。

升级的当前方案(版本: 7.2.x/7.3.x/9.4.x )

如果 Unified Manager 管理较大的 ONTAP 覆盖范围或实例管理 ONTAP 节点的时间较长、则 Continuous _Event_参与者 和 Continuous _Event_学员 _Stats 表中“ OPM ”模式下的记录数会增加。这会导致从 7.3.x/7.3.x 版升级失败并从 7.3.x->9.5 版升级。发生这种情况的原因如下:

  • 表大小: Continuous _Event_参与者 和 Continuous _Event_学员 _Stats

注:对于 Active IQ Unified Manager 9.5P1 和 9.6RC1 、超时值默认为 18000 秒( 5 小时)。这些问题目前已得到跟踪、我们将在下一个 Active IQ Unified Manager 版本中获得更好的解决方案。

解决方案

我们提出了一套前提条件和最佳实践、这将帮助您从 7.2.x/7.3.x/9.4x/9.5 版本升级 Unified Manager 。

Active IQ Unified Manager 升级的前提条件(从 7.2.x/7.3.x/9.4.x 到 9.5 )

如果在计划从 7.2.x 、 7.3.x 、 9.4.x 至 >9.5 版进行 Active IQ Unified Manager 升级之前遵循这些准则,这将始终是有益的

  1. 升级前进行完整备份

在升级之前备份系统。

注:默认情况下,系统不允许您在 GUI 中执行手动完整备份。您需要刷新一些日志以打破备份序列链。这就要求您按照[1]“ Unified Manager 托管于物理系统和 / 或非 VMware Infrastructure ”一节中的说明参与 NetApp 支持

VMware 上的 Unified Manager 实例

  • 如果是 vApp ,请执行 VMware 快照

执行以下操作:

  1. 在 vSphere 客户端中,单击主页 > 清单 > VM 和模板
  2. 选择安装 Unified Manager 虚拟设备的虚拟机( VM )。
  3. 如果 Unified Manager VM 正在运行,请导航至 [ 摘要 ]>[ 命令 ]>[ 关闭客户机 ] 。
  4. 创建 Unified Manager VM 的备份副本(如 Snapshot 或克隆)以创建应用程序一致的备份。
  5. 从 vSphere 客户端启动 Unified Manager VM
  • 如果是 VMware 托管的 RHEL/CentOS/Windows VM 、请停止 Unified Manager 和 MySQL 服务并执行快照

Unified Manager 由物理系统和 / 或非 VMware Infrastructure 托管

如果该实例不是由 VMware 托管的、则需要强制执行完全备份。参与 NetApp 支持并执行以下步骤:(有关详细信息,请参阅知识库:如何在 ActiveIQ Unified Manager 7.2 至 9.6 版中启动新的增量备份链

  1. 在提示符处,键入以下命令设置数据库:

use mysql;

  1. 从 MySQL 备份实用程序中清除日志,方法是运行以分号结尾的以下每个命令;依次执行:

FLUSH LOGS;

PURGE BINARY LOGS BEFORE CURRENT_TIMESTAMP;

  1. 然后输入:

exit

  1. 立即从 GUI 触发备份。

注意:当完全备份处于会话中时、 MySQL 表被锁定、这意味着在完成完整备份过程之前、不能将新的“集群监控 / 轮询”更新添加到 Active IQ Unified Manager MySQL 数据库。这也意味着在完成完完整备份之前客户的服务中断。

警告:如果不按照上述过程执行快照或备份、可能不一致且可能不可用。因此,您将没有备份。

确保您准确地执行了所有的操作步骤。

  1. 表空间大小

要防止升级失败、用户需要检查 "opm" 模式表中的条目数:continuous_event_participantcontinuous_event_participant_stats

使用以下方法检查表大小(以 MB 为表示)

  1. mysql CLI 中执行以获得对数据库的访问权限
  2. 键入以下查询以查找以 MB 为单位的表大小

SELECT table_name AS `Table`,

round(((data_length + index_length) / 1024 / 1024), 2) `Size in MB`

FROM information_schema.TABLES

WHERE table_schema = "opm"

AND table_name IN ('continuous_event_participant',

'continuous_event_participant_stats');

输出类似于以下内容:

1089470.png

从数据库中查看表大小

如果表的大小明显较大、即两个表的总和超过 700 MB 、请与 NetApp 支持联系以删除表中的数据: Continuous _Event_学员 和 Continuous _Event_学员 _Stats

  1. 升级超时时间偏移

如果客户将 7.2.x/7.3.x 升级到 9.4 或 7.3.x 、升级到 9.5 (不更改 Burt 1214422 中提到的超时时间)、如果[2]他们拥有相当数量的历史数据、他们可能会进入 Burt 1214422 。因此,建议让 NetApp 支持来缩小这两个表:连续 _ 事件 _ 参与方和连续 _ 事件 _ 参与方 _ 统计数字

立即开始升级过程。

减少 OPM 架构下的记录数

如果增加超时仍然不起作用并且升级失败、请联系支持部门以检查是否可以减少 "opm" 模式表中的记录数(连续 _event_參 與者和连续 _event_參 與者 _stats )。

有关更多信息、请参见 KB :由于 Continuous _Event_学员 和 Continuous _Event_学员 _stats 表的迁移很大、从 Unified Manager 7.3 升级到 9.4 或更高版本失败

备份和还原最佳实践

随着时间的推移,增量备份可能会导致大量文件。在还原时,如果客户不使用 Snapshot 选项(由非 VMware 环境托管的实例),则这可能需要花费大量的时间。为缓解此问题、 NetApp 建议遵循一些最佳实践以优化备份和恢复时间表:

  1. 在 Unified Manager GUI 中将备份保留计数保持在 30 。
  2. 对于大规模客户、建议遵循知识库:如何启动新的增量备份链
  • 每月强制执行完整备份(在 GUI 中执行临时备份)

注:要执行完整备份、请选择非工作时间、因为完成备份可能需要几个小时。在此期间、采集引擎将不会响应、这相当于监控中断

  1. 如果 Unified Manager 是从 RHEL/CentOS/Windows 托管的:
    1. 将备份路径配置为单独的远程路径
    2. 作为最佳实践、您可以在安装 Unified Manager 版本的情况下安装新的 VM 备用。从*7.zip .sql步骤 1 恢复最新的文件和文件(如果需要)
  2. 在由 RHEL 或 OVA ( vApp )托管的 Unified Manager 实例上、由于文件/系统已满而导致完全备份失败。此问题已在 Burt1213753 中解决[3];请参见 KB:OnCommand Unified Manager Backup Failing with "Error Occured While Creating Backup Archive/data/ocum-Backup/DatabasasDum-repo /ocum_MySQL_Full_Backup.sql.7z"

您可以在以下位置找到错误日志:

Linux/VApp :

/var/log/ocum/ocum-error.log

Windows

\ProgramData\NetApp\OnCommandAppData\ocum\log\ocum-error.log

典型错误如下所示:

2018-09-09 07:14:32,993 ERROR [oncommand] [taskScheduler-4] [Backup|ScheduleBackup] [c.n.dfm.impl.backup.BackupArchiver] Error Occured while creating backup archive /data/ocumbackup/database-dumps-repo/ocum_mysql_full_backup_1536427804511.sql.7z cause :

7-Zip (a) [64] 16.02 : Copyright (c) 1999-2016 Igor Pavlov : 2016-05-21 p7zip Version 16.02 (locale=en_US.UTF-8,Utf16=on,HugeFiles=on,64 bits,4 CPUs Intel(R) Xeon(R) CPU E5-2630 v3 @ 2.40GHz (20651),ASM,AES-NI)

Scanning the drive:

1 file, 89533818092 bytes (84 GiB)

原因

如果根分区中没有足够的空间用于压缩备份文件,备份可能会失败。

解决方案:

尝试增加根分区中的空间。如果无法增加根分区、请与 NetApp 支持部门联系;请参见 Burt1213753[4] 。请求 NetApp 支持以帮助执行 KB 中提到的步骤: OnCommand Unified Manager 备份失败、 " 创建备份归档 /data/ocum-backup/databasasdump -repo /ocum_mySQL_full _backup.sql.7z"

恢复:

这些步骤可以帮助您更快地恢复:

  1. 如果您有 VMware 快照、则可以在几分钟内完成还原。
  2. 如果这不起作用(或者 Unified Manager 不是由 VMware 托管的),请按照本节中的说明从备份路径进行还原。

其他信息

附加信息 _text